Journals / Bilişim Teknolojileri Dergisi / 2026 / Cilt: 10 Sayı: 3

SIP Saldırıları ve Güvenlik Yöntemleri

Pages
301–310
Publication Date
2017-07-31
🏛️Bibliographic metadata and full text access for this article are provided via DergiPark.
DergiPark Record ↗
✨

AI Summary & Key Takeaways

AI Insight
⚡ TL;DR(Too Long; Didn't Read)

Paket yakalama yazılımları ile mesajların ele geçirilmesini önlemek için ise kriptolama teknolojilerinin kullanılmasının gerekli olduğu görülmüştür. 

📌 3 Key Takeaways

🎯
Objective & Hypothesis:Bu çalışmada, sesin gerçek zamanlı olarak IP üzerinden iletilmesi (VoIP) için kullanılan Session Initiation Protocol (SIP) güvenlik açıkları incelenmiş ve çözüm yöntemleri önerilmiştir.
📊
Key Findings & Data:Gerçekleştirilen saldırıların sistemdeki olumsuz etkilerini en aza indirmek için ise, IDS/IPS olarak kullanılan yazılım ile çeşitli kurallar tanımlanmış ve saldırı anında alarm vermesi sağlanmıştır.
💡
Conclusion & Impact:Paket yakalama yazılımları ile mesajların ele geçirilmesini önlemek için ise kriptolama teknolojilerinin kullanılmasının gerekli olduğu görülmüştür. 
🔬Design:Araştırma Makalesi
📍Scope:Comprehensive Sample
⚙️Variables:SIP · SIP saldırı · SIP güvenlik

Özet

Bu çalışmada, sesin gerçek zamanlı olarak IP üzerinden iletilmesi (VoIP) için kullanılan Session Initiation Protocol (SIP) güvenlik açıkları incelenmiş ve çözüm yöntemleri önerilmiştir. Günümüzde, SIP tüm VoIP sunucu, IP telefon, yazılım tabanlı telefon ve VoIP çalışan uygulamalar için kullanılan en yaygın protokol olup tüm hepsi tarafından da desteklenmektedir. SIP protokolünün bu kadar popüler ve geniş kapsamda kullanılması birtakım tehditleri de beraberinde getirmektedir. Kullanıcılar arasındaki bağlantının koparılması, sunucuya ulaşılamaması, hizmet kesintisi, görüşmelerin manipüle edilmesi vb. amaçları taşıyan birçok saldırı ile istenmeyen sonuçlar doğabilir. Özellikle savunmasız sistemlerde uygulaması kolay olan DoS hizmet kesintisi, telekulak ve ortadaki adam saldırılarının gerçekleştirilmesi bu çalışmanın temelini oluşturmuştur. Bu saldırıları gerçekleştirebilmek için gerekli olan yazılım ve araçlar incelenmiştir. Gerçekleştirilen saldırıların sistemdeki olumsuz etkilerini en aza indirmek için ise, IDS/IPS olarak kullanılan yazılım ile çeşitli kurallar tanımlanmış ve saldırı anında alarm vermesi sağlanmıştır. Paket yakalama yazılımları ile mesajların ele geçirilmesini önlemek için ise kriptolama teknolojilerinin kullanılmasının gerekli olduğu görülmüştür. 

🔖

Cite This Article

Yüksel, M., Öztürk, N. (2017). SIP Saldırıları ve Güvenlik Yöntemleri. Bilişim Teknolojileri Dergisi, Cilt: 10 Sayı: 3, 301–310. https://doi.org/10.17671/gazibtd.331042

📄 Full Text PDF Viewer

📄

PDF görüntüleyici hazırlanıyor...

References (6)

  1. A. Steffen, D. Kaufmann, Andreas Sticker, Comparative overview of the security mechanisms recommended by the SIP standard, LectureNotes in Informatics (LNI) P-55, BonnerKöllenVerlag 2004. [2] V. Kumar, M. Korpi, S. Sengodan, IP Telephony with H323: Architectures for Unified Networks and Integrated Services, John Wiley&Sons, 2001. [3] K.K. Tan, H.L. Goh, “Session Initiation Protocol, Industrial Technology”, IEEE ICIT ’02. 2002
  2. IEEE International Conference, IEEE ICIT’02, THAILAND, 2002, 2, pp. 1310 - 1314, 11-14 Dec. 2002. [4] R. Zhang, X. Wang, X. Yang, X. Jiang, “On the billingvulnerabilities of SIP-basedVoIPsystems”, Computer Networks, 54(11), 1837-1847, 2010. [5] A. D. Keromytis, “A ComprehensiveSurvey of Voice over IP Security Research”, IEEE Communications Surveys&Tutorials, 14(99), 2012. [6] E. Y. Chen, “DetectingDoSattacks on SIP systems”, 1st IEEE Workshop on VoIP Management and Security 2006, pp. 53-58 [7] Q. QIU, Study of Digest Authentication for Session Initiation Protocol (SIP), Master’s Project Report, University of Ottawa, December, 2003. [8] C. Shen, E. Nahum, H. Schulzrinne, C. Wright, “The Impact of TLS on SIP Server Performance: Measurement and Modelling”, IEEE/ACM Transactions on Networking, 20(4), 1217-1230, 2012. [9] S. Islm, M. Rahman, “Voip End-to-End Security Using S/MIME and a Security Toolbox”, Global Journal of Computer Science and Technology, 14(5), 39-42, 2014. [10] E. C. Cha, H. K. Choi and S. J. Cho, "Evaluation of Security ProtocolsfortheSessionInitiation Protocol,"2007 16th International Conference on Computer Communications and Networks, HI, 2007, Honolulu, pp. 611-616. [11] Yang C-C, Wang R-C, Liu W-T, ”Secure authentication scheme for session initiation protocol”, ComputSecur, 24(5), 381–386, 2005 [12] M.Voznak and J. Safarik "DoS attacks targeting SIP server and improvements of robustness", International Journal of Mathematics and Computers ın Sımulatıon, 177-184, 2012. [13] I. Özçelik, R.R. Brooks, "Deceiving entropy based DoS detection", Computers&Securıty, 48, 234-245, 2015. [14] H.Sengar, D. Wıjesekera, H. Wang, S. Jajodia,"VoIP Intrusion Detection Through Interacting Protocol State Machines", 2006, Dependable Systems and Networks, 2006. [15] I.Taş, O. Özbirecikli, U. Çağal, E. Taşkın H. taş,"SIP Kayıt Silme Saldırısı Anatomisi ve Savunma Stratejileri", SIU, 2014. [16]Y.Ding and G.Su, “Intrusion detection for signal based SIP attacks through timed HCPN”, Int. Conf. On Availability, Reliability and Security. IEEE,2007. [17] E. Rescorla, “ SSL and TLS Designing and Building Secure Systems”. Addison Wesley, 2000. [18] J. Tiller, “A technical guide to IPSec Virtual Private Networks” Auerbach publications,2000. [19] J. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Spark, M. Handley, and E. Schooler, ” Session Initiation Protocol”, RFC 3261 IETF,2002. [20] D. Seo, H. Lee, and E. Nuwere, “Detecting More SIP Attacks on VoIP Services by Combining Rule Matching and State Transition Models”, IFIP International Federationfor Information Processing, Volume 278; Proceedings of the IFIP TC 11 23rd International Information Security Conference,397-411, 2008. [21] J. Tang, Y. Cheng and Y.Hao, “Detection and prevention of SIP flooding attacks in voiceover IP networks”, 2012
  3. Proceedings IEEE INFOCOM, Orlando, FL, 2012, pp. 1161-1169. [22] S. Ehlert, G. Zhang, D. Geneiatakis, G. Kambourakis, T. Dagiuklas, J. Markl, D. Sisalem, “Two layer Denial of Service prevention on SIP VOIP Infastructure”, Computer Communications, 31, 2443–2456, 2008. [23] H. Y. Lam, C. P. Li, S. T. Chanson and D. Y. Yeung, "A Coordinated Detection and Response Scheme for Distributed Denial-of-Service Attacks,"2006 IEEE International Conference on Communications, 2006, İstanbul, pp. 2165-2170. [24] T.Al-Kharobı, M.Al-Mendhar, “Comprehensive Comparison of VoIP SIP Protocol Problems and Cisco VoIP System”, International Journal of Network Security & Its Applications, 4(4), 137-152, 2012. [25] A. B. Johnston, SIP: Understanding the Session Initiation Protocol, Artech House, 2009, Boston, 3rdEdition. [26] Internet: M. Collier, Basic Vulnerability Issues for SIP Security, http://download.securelogix.com/library/SIP_Security030105.pdf, 01.02.2017 [27] D. Sisalem, J. Kuthan and S. Ehlert, “Denial of service attacks targeting a SIP VoIP infrastructure: attack scenarios and prevention mechanisms”, IEEE Network, 20(5), 26-31, 2006. [28] Internet: J. Franks, P. Hallam-Baker, J. Hostetler, S. Lawrence, P. Leach, A. Luotonen, L.Stewart, HTTP Authentication: Basic and Digest Access Authentication, 1999,RFC-2617, http://www.rfc-base.org/txt/rfc-2617.txt, 01.02.2017. [29] P. Fontanini, VOIP Security, Master Thesis, Gjovik University College, Dep. Of Comp. Science and Media Tech., 2008. [30] Internet: T. Dierks, C. Allen, The TLS Protocol”, IETF 1999, RFC 2246, http://www.rfc-base.org/txt/rfc-2246.txt, 01.02.2017. [31] D. Geneiatakis et al.,, “Survey of security vulnerabilities in session initiation protocol”, IEEE Communications Surveys&Tutorials, 8(3), 68-81,3rd. Qtr. 2006. [32] J. S. Tiller, A Technical Guide to IPSec Virtual Private Networks, New York, Auerbach Publications,December- 2000. [33] G. Asghar, Security Issues of SIP, Master Thesis, Blekinge Institute of Technology, School of Engineering June- 2010.
  4. A. Steffen, D. Kaufmann, Andreas Sticker, Comparative overview of the security mechanisms recommended by the SIP standard, LectureNotes in Informatics (LNI) P-55, BonnerKöllenVerlag 2004. [2] V. Kumar, M. Korpi, S. Sengodan, IP Telephony with H323: Architectures for Unified Networks and Integrated Services, John Wiley&Sons, 2001. [3] K.K. Tan, H.L. Goh, “Session Initiation Protocol, Industrial Technology”, IEEE ICIT ’02. 2002
  5. IEEE International Conference, IEEE ICIT’02, THAILAND, 2002, 2, pp. 1310 - 1314, 11-14 Dec. 2002. [4] R. Zhang, X. Wang, X. Yang, X. Jiang, “On the billingvulnerabilities of SIP-basedVoIPsystems”, Computer Networks, 54(11), 1837-1847, 2010. [5] A. D. Keromytis, “A ComprehensiveSurvey of Voice over IP Security Research”, IEEE Communications Surveys&Tutorials, 14(99), 2012. [6] E. Y. Chen, “DetectingDoSattacks on SIP systems”, 1st IEEE Workshop on VoIP Management and Security 2006, pp. 53-58 [7] Q. QIU, Study of Digest Authentication for Session Initiation Protocol (SIP), Master’s Project Report, University of Ottawa, December, 2003. [8] C. Shen, E. Nahum, H. Schulzrinne, C. Wright, “The Impact of TLS on SIP Server Performance: Measurement and Modelling”, IEEE/ACM Transactions on Networking, 20(4), 1217-1230, 2012. [9] S. Islm, M. Rahman, “Voip End-to-End Security Using S/MIME and a Security Toolbox”, Global Journal of Computer Science and Technology, 14(5), 39-42, 2014. [10] E. C. Cha, H. K. Choi and S. J. Cho, "Evaluation of Security ProtocolsfortheSessionInitiation Protocol,"2007 16th International Conference on Computer Communications and Networks, HI, 2007, Honolulu, pp. 611-616. [11] Yang C-C, Wang R-C, Liu W-T, ”Secure authentication scheme for session initiation protocol”, ComputSecur, 24(5), 381–386, 2005 [12] M.Voznak and J. Safarik "DoS attacks targeting SIP server and improvements of robustness", International Journal of Mathematics and Computers ın Sımulatıon, 177-184, 2012. [13] I. Özçelik, R.R. Brooks, "Deceiving entropy based DoS detection", Computers&Securıty, 48, 234-245, 2015. [14] H.Sengar, D. Wıjesekera, H. Wang, S. Jajodia,"VoIP Intrusion Detection Through Interacting Protocol State Machines", 2006, Dependable Systems and Networks, 2006. [15] I.Taş, O. Özbirecikli, U. Çağal, E. Taşkın H. taş,"SIP Kayıt Silme Saldırısı Anatomisi ve Savunma Stratejileri", SIU, 2014. [16]Y.Ding and G.Su, “Intrusion detection for signal based SIP attacks through timed HCPN”, Int. Conf. On Availability, Reliability and Security. IEEE,2007. [17] E. Rescorla, “ SSL and TLS Designing and Building Secure Systems”. Addison Wesley, 2000. [18] J. Tiller, “A technical guide to IPSec Virtual Private Networks” Auerbach publications,2000. [19] J. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Spark, M. Handley, and E. Schooler, ” Session Initiation Protocol”, RFC 3261 IETF,2002. [20] D. Seo, H. Lee, and E. Nuwere, “Detecting More SIP Attacks on VoIP Services by Combining Rule Matching and State Transition Models”, IFIP International Federationfor Information Processing, Volume 278; Proceedings of the IFIP TC 11 23rd International Information Security Conference,397-411, 2008. [21] J. Tang, Y. Cheng and Y.Hao, “Detection and prevention of SIP flooding attacks in voiceover IP networks”, 2012
  6. Proceedings IEEE INFOCOM, Orlando, FL, 2012, pp. 1161-1169. [22] S. Ehlert, G. Zhang, D. Geneiatakis, G. Kambourakis, T. Dagiuklas, J. Markl, D. Sisalem, “Two layer Denial of Service prevention on SIP VOIP Infastructure”, Computer Communications, 31, 2443–2456, 2008. [23] H. Y. Lam, C. P. Li, S. T. Chanson and D. Y. Yeung, "A Coordinated Detection and Response Scheme for Distributed Denial-of-Service Attacks,"2006 IEEE International Conference on Communications, 2006, İstanbul, pp. 2165-2170. [24] T.Al-Kharobı, M.Al-Mendhar, “Comprehensive Comparison of VoIP SIP Protocol Problems and Cisco VoIP System”, International Journal of Network Security & Its Applications, 4(4), 137-152, 2012. [25] A. B. Johnston, SIP: Understanding the Session Initiation Protocol, Artech House, 2009, Boston, 3rdEdition. [26] Internet: M. Collier, Basic Vulnerability Issues for SIP Security, http://download.securelogix.com/library/SIP_Security030105.pdf, 01.02.2017 [27] D. Sisalem, J. Kuthan and S. Ehlert, “Denial of service attacks targeting a SIP VoIP infrastructure: attack scenarios and prevention mechanisms”, IEEE Network, 20(5), 26-31, 2006. [28] Internet: J. Franks, P. Hallam-Baker, J. Hostetler, S. Lawrence, P. Leach, A. Luotonen, L.Stewart, HTTP Authentication: Basic and Digest Access Authentication, 1999,RFC-2617, http://www.rfc-base.org/txt/rfc-2617.txt, 01.02.2017. [29] P. Fontanini, VOIP Security, Master Thesis, Gjovik University College, Dep. Of Comp. Science and Media Tech., 2008. [30] Internet: T. Dierks, C. Allen, The TLS Protocol”, IETF 1999, RFC 2246, http://www.rfc-base.org/txt/rfc-2246.txt, 01.02.2017. [31] D. Geneiatakis et al.,, “Survey of security vulnerabilities in session initiation protocol”, IEEE Communications Surveys&Tutorials, 8(3), 68-81,3rd. Qtr. 2006. [32] J. S. Tiller, A Technical Guide to IPSec Virtual Private Networks, New York, Auerbach Publications,December- 2000. [33] G. Asghar, Security Issues of SIP, Master Thesis, Blekinge Institute of Technology, School of Engineering June- 2010.